Asia Pacific Data Center Customers facing intermittent issues.

Incident Report for ClayHR

Resolved

This incident has been resolved. Team will continue to monitor in the coming days.
Posted Jan 30, 2026 - 12:34 UTC

Monitoring

The fix is now live, and the team is monitoring the fix. Thank you for your patience.
Posted Jan 30, 2026 - 12:21 UTC

Identified

The underlying issue has been identified and a fix is currently in process. ETA is now about 15 minutes and new updates will posted here shortly.
Posted Jan 30, 2026 - 12:08 UTC

Investigating

Asia Pacific Data Center Customers are facing intermittent issues. Team is currently investigating the issue.
Posted Jan 30, 2026 - 11:42 UTC
This incident affected: Production Applications (Job-Board Application, HCM Application).